View Full Version : Microsoft Bob

Louie C.
12-02-2002, 08:38 PM
Does anyone know where I can download a copy of Microsoft Bob?

It may sound kind of silly, but I want to play around in it :)

12-06-2002, 09:43 AM
What in the world is Microsoft Bob? :unsure:

Louie C.
12-06-2002, 08:11 PM
Microsoft Bob is a shell for Windows 3.x and higher that was marketed for the novice user. It gave the computer screen an interface that looked like a room in a house.

Microsoft Bob was also the beginning of the Office Assistant as there were many characters that would guide you around your "home".

I have never run it, but everything I have read has said stuff similar to this. I really want to try it and I still can't find it.

Louie C. B)

12-06-2002, 08:29 PM
Does it come with Microsoft Office? Do you even know?

Louie C.
12-07-2002, 07:19 PM
It was released in 1995 as its own program for about $100.

The only thing about Office is that the Office Assistant was based around the Microsoft Bob guides. Other than that, Office and Bob have absolutely nothing to do with each other.

Louie C. B)

12-07-2002, 08:03 PM
Do you know the website to get it at?

Louie C.
12-08-2002, 02:24 PM
That's what I'm trying to find out. I have never run it, and I am trying to find it. If anyone knows where Microsoft Bob can be found for download, PLEASE let me know!

Louie C. B)

12-08-2002, 03:19 PM
I tryed doing a search for Microsoft Bob at Microsoft.com (http://www.microsoft.com) and didn't find it. I bet Microsoft no longer supports Microsoft Bob.

OldVersion.com Admin
12-08-2002, 03:57 PM
Out of curiousity, I googled it.

http://www.techtv.com/screensavers/showtel...3316324,00.html (http://www.techtv.com/screensavers/showtell/story/0,24330,3316324,00.html)

seems it has existed. Don't know why you would want it. I don't think it'd be legal to distribute it anyway.

12-09-2002, 07:36 PM
I looked at that page and it had nothing about downloading Microsoft Bob.

Louie C.
12-09-2002, 10:09 PM
I only want it as something to play around in. It looks somewhat interesting and I just want to check it out. I just can't find it anywhere!

Louie C. B)

12-11-2002, 04:07 PM
I found it! (I've been looking for months for this as well).
You can find the link to it about 3/4 of the way down this page:

Edited by Therese: Microsoft Bob is not freeware or shareware

12-11-2002, 09:13 PM
Originally posted by Tom@Dec 11 2002, 05:07 PM
I found it! (I've been looking for months for this as well).
You can find the link to it about 3/4 of the way down this page:
edited by Therese
Excellent find! The Microsoft Bob search comes to an end.

However, there is still one unanswered question left. On that web page, it says that Microsoft Bob is freeware. I tried looking for information about current status of Microsoft Bob and it is impossible to find. I must note that Microsoft is trying hard to erase Bob from memory. There are no official Microsoft mentions of it anywhere. Anyone know the current status?

12-12-2002, 02:23 PM
That page says: "guess it ain't freeware"

12-12-2002, 06:21 PM
I didn't see nothing at the bottom about downloading Microsoft Bob.

OldVersion.com Admin
12-12-2002, 06:29 PM
Originally posted by SSS@Dec 12 2002, 07:21 PM
I didn't see nothing at the bottom about downloading Microsoft Bob.

MS-Bob 1.0
Its only one of THE MOST annoying things ever made... the Office Asst and little search puppy in XP are the bastard children of BOB, basically...

it's there.

Louie C.
12-13-2002, 11:18 PM
Nice going! How long did it take you to find this?

Louie C. B)

12-13-2002, 11:32 PM
Well, I had been looking for this off and on since mid-September, but I actually wasn't searching for it when I stumbled across it. When I clicked the download link to it and it actually worked -- I was amazed.

Yep, MS Bob was even worse than I imagined -- especially the purple speaking elephant that is in the geography game.
It's a true classic.

Louie C.
12-14-2002, 12:00 PM
I downloaded it and tried to install it. It installed just fine, but it won't run. How do you get it to work???

Please help me.

Louie C. B)

12-14-2002, 01:32 PM
Well thats dumb. Did you read the system requirements? It might not be compatible with your computer.

12-14-2002, 02:43 PM
Originally posted by Louie C.@Dec 14 2002, 01:00 PM
I downloaded it and tried to install it. It installed just fine, but it won't run. How do you get it to work???

Please help me.

Louie C. B)
Well, I'll try to help, but I need more information first.
First, what operating system, computer speed, sound card and how much memory do you have?

Second, does the program show any error messages, or what happens when you try to run it?

Third, if I recall correctly, when you get to the end of the installation, it asks if you want to restart your computer now or later. If you choose later, the installation won't be complete, and something won't install right. (If you did this, delete the C:\MSBOB directory, and reinstall.)

Also, make sure to install it to C:\MSBOB, not to Program Files\MSBOB, because BOB is 16-bit, and might not support directories that are longer than 8 letters or have spaces in them.

(I used Win95 OSR2 with 64MB RAM, and a SoundBlaster 16 on on AMD 1.1Ghz speed computer.)

Note to SSS: That wasn't exactly a helpful comment.

Louie C.
12-14-2002, 06:13 PM
I am on a 1.1 GHz Celeron with 128 MB RAM & Windows Millennium.

I get an error about Utopia.dll not found.

What can be causing that?

Louie C. B)

12-14-2002, 06:16 PM
If you are missing Utopia.dll, you probably have to reinstall Windows ME. I don't think you have to do this, but this is the only suggestion in mind.

Louie C.
12-14-2002, 06:33 PM
Utopia.dll comes with Bob, not with Me. I sort of got it to work.

I was in the Bob Home, but the GeoSafari and other things wouldn't work.

I exited, and then went back to it later, and the sounds were gone from Bob and the only way I could exit out of the program was to manually end the task or hope for a program crash.

What can I do to make it work like it should?

Louie C. B)

12-14-2002, 07:28 PM
running 98 and it works just fine

12-14-2002, 08:11 PM
To Louie C:
OK, I tried it under Windows ME and here's what I found. Probably the same thing happened to you.

When I got to the end of the installation, it told me that the system must be rebooted, but the reboot button didn't reboot the computer. You would be stuck at that stage of the install unless you chose exit.

At that point the installation tells you to run "C:\windows\_msrstrt.exe" from DOS.

Well, you can't do that because Windows ME doesn't let you restart in DOS mode.
So instead, choose Start | Run | "C:\windows\_msrstrt.exe" (Without the quotes). On the screen it will say that it is attempting to restart your computer, but it won't. You will need to choose Start | Shut down... | Restart.

Once you get back into Windows after your computer has restarted, Bob should run fine.


I'm guessing that I know what you did. You probably ran the installation, then just restarted your computer. If you did that, I think that all you need to do is run "C:\windows\_msrstrt.exe", and restart. If that doesn't work, delete "C:\msbob" and reinstall following the steps above.

Also note: "_msrstrt.exe" deletes itself and the batch file "_msrstrt.bat" after it is run.

Last edited by Tom at Dec 14 2002, 09:16 PM

12-14-2002, 09:02 PM
OK. I'll try this. Do you think it'll run on XP?

Louie C. B)

Last edited by hockeyman16 at Dec 14 2002, 09:02 PM

12-14-2002, 09:24 PM
So, I tried it out on XP. Good news, it installs better on XP than ME.
But a couple of things were a little strange. When I first ran Bob after installing, it ran a DOS window -- the window had no text in it. So, after about 30 seconds, I hit the X in the uper right corner and closed it. Then I tried running it again, Bob started, but when I exited the GeoSafari program, it generated an error. So, I restarted the computer, and now Bob seems to be working fine.

Of course, you will need to be logged in as a user with administrative access privileges for sure to install, and maybe to run it as well.

Hey, let us know if you get it to work on Windows ME, or XP.

12-14-2002, 09:30 PM
OK. Cool. Thanks for helping me out. I'll try it on XP in a little bit.

Louie C. B)

12-14-2002, 09:31 PM
Anytime. Glad to help.

12-15-2002, 09:54 AM
I installed it on XP, and I got the DOS window. I closed it after about 30 seconds like you did, and I got the Utopia.dll error.

I can't seem to get past that.

Louie C. B)

12-15-2002, 10:21 AM
You said that Utopia.dll comes with Microsoft Bob. Did it install it during installation?

Last edited by SSS at Dec 15 2002, 10:22 AM

12-15-2002, 11:04 AM
Yes it did. It is in the directorty C:\MSBOB, but for whatever reason, Home.exe will not run. It just gives that error message. If I copy Home.exe into the C:\MSBOB directory, it will run, but most of the Bob programs will not run. I can not even change the guide from Rover to anyone else!

Here is exactly what happens on my XP computer:

1) Installation works just fine. It asks me to restart, so I click Restart, but instead, it just logs me out.

2) I log back in and try running Microsoft Bob, but I get that DOS window.

3) I wait awhile and close the DOS window only to be greeted by the Utopia.dll error.

What can I do?

Louie C. B)

12-15-2002, 11:29 AM
If it logs you out, restart by clicking the Start menu and click shut down. Select the Restart the Computer? option. Click Yes. If this is different, then im sorry. I am running Windows 95. You probably are going to restart the computer on your own. Sorry. :( Note:Restart after you log in.

Last edited by SSS at Dec 15 2002, 11:35 AM

12-15-2002, 12:59 PM
No luck. It just doesn't want to work. I always get the 'Can not find Utopia.dll' error message, even after restarting my computer like you said.

What can I do???

Louie C. B)

Last edited by hockeyman16 at Dec 15 2002, 12:59 PM

12-15-2002, 03:11 PM
It probably is a hidden file by default and the program could not find the file. Go to C:/MSBOB. If you see plus # hidden on the status bar, then there are some files missing. # indicates how much files are hidden. To show the hidden files, click the View menu and click options. Go to the View tab. Click the Show all files option. Hope this helps.

Last edited by SSS at Dec 15 2002, 03:12 PM

12-15-2002, 06:18 PM
There are no hidden files. I don't have the slightest clue what the problem could be. Everyone else seems to have gotten it running smoothly. I've tried it on two computers with two different operating systems to no avail.

Please someone help me!

Louie C. B)

Last edited by hockeyman16 at Dec 15 2002, 08:03 PM

12-15-2002, 07:47 PM
Did you try reinstalling Bob? If you didn't, reinstall it and see what happens.

Last edited by SSS at Dec 15 2002, 07:47 PM

12-15-2002, 08:03 PM
I've tried reinstalling a million times with no luck.

Louie C. B)

12-15-2002, 11:38 PM
God, I don't know why it won't work for you...

However, you say that if you copy Home.exe into the C:\MSBOB directory some of it will run. Have you tried copying (not moving, but copying) C:\MSBOB\utopia.dll to the C:\MSBOB\Home directory?

Or try copying C:\MSBOB\utopia.dll, along with utopia.ldb, and utopia.mdb to the C:\MSBOB\Home directory.

This is just a guess, I can't seem to duplicate your problem anymore.

I guess you could try re-downloading the file, but that's probably not going to change anything.

12-16-2002, 07:09 AM
I'll try as soon as I get home and I'll keep everything posted.

BTW...does your copy say something like "Gateway 2000 Edition"?

Louie C. B)

12-16-2002, 02:49 PM
Yep, Gateway 2000 Edition (That's why the first room in the Bob home looks like a barn.)

12-16-2002, 09:54 PM
No luck. Same as if I had copied home.exe into the C:\MSBOB folder.

I even reinstalled again and had the same lousy luck. Is there something that you do that I don't?

Louie C. B)

Last edited by hockeyman16 at Dec 16 2002, 09:54 PM

12-16-2002, 11:23 PM
This is a longshot, but worth a try.
On the Windows ME machine, delete the C:\MSBOB
directory, and reinstall (don't tell it to start
with Windows when the installer asks). At the end of the
installation, choose Exit (don't choose restart).

Now, restart your machine, but have it boot from
a Windows ME boot floppy disk.* From the boot
screen that appears, one of the options is
'Minimal Boot'. Select that and at the prompt
type C:\windows\_msrstrt.exe

Your computer should restart. Take out the floppy,
and let it load into Windows normally. Now, try
to run MSBob (from its entry in the Start |
Programs | MSBob location).

* If you don't have a boot floppy disk, you can make
one from the tab in the Add/Remove Programs area of
Control Panel.

12-18-2002, 03:55 PM
No luck.

Louie C. B)

12-19-2002, 03:01 AM
Well, admit defeat. I don't know why it won't work for you, but realize that there is a reason that MS discontinued MS Bob, and that could well be one of them.

On a lighter note, here's a link to a parody of MS Bob, called Bubba:
also to the runtime file vbrun300.dll (which you may already have)
http://download.microsoft.com/download/vb3...N-US/VB3Run.exe (http://download.microsoft.com/download/vb30/Utility/1/W9XNT4/EN-US/VB3Run.exe)