Welcome guest, is this your first visit? Create Account now to join.
  • Login:

Welcome to the OldVersion.com Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Results 1 to 4 of 4
  1. #1

    Default CoolEdit - Experienced User - No Noise Reduction but the window is there.

    This is an odd thing that will need someone with the brain to figure it out. Heres' the story ...


    OS = Win98SE
    Sound Card is CMedia CMI8768 New card that's working perfectly.

    I have used cooledit in the past and am familiar with its operation. I've never had
    any problems with it.

    Now I am not able to use the noise reduction. The button or menu selection is there but the lower window section
    for CAPTURING NOISE is greyed out. I have some old FFT noise files that I've tried to load but
    they won't load or at least there's no effect when I try to load them.

    Suggestions ?
    I wonder if I might be missing some DLLs on my system. Other than the NR problem cooledit seems to work just fine.

    I looked at the files in the directory and there is one named NOISE.XFM which appears to be an executable
    cooledit file. If that's the NOISE REDUCTION module it's there. As I say I'm familiar with how to use cooledit's
    NOISE REDUCTION. If I could send a screen cap somewhere you can see what I see.

    VERSIONS - 134a, 1.53
    Two versions I've tied that have NR , 1.34a and 1.53 are both not working the same way. That is the NR choice is there and the window opens but if I select noise there
    is no way to click 'Capture Noise'. It's greyed out.

    I have selected the two choices of NOISE REDUCTION and SAVING RESULTS in the startup screen.
    My temp directory is my E: drive which is empty.. there's gigs of space available.
    I'm using the root not a folder. It's laziness. I've done this before with no problems.


    I've tried changing the values on the NR screen. I've made sure I had enough samples and I've tried to make sure
    I didn't have too much (whatever).. I've used it before with no problems. In fact it's worked perfectly.
    I recorded new samples from audio but NR didn't operate. I tried loading old wavs and NR didn't work.

    I used the downloads from Old Versions. I have 'installed' by unzipping the file(s) in
    a directory. Then I run it from cool.exe.

    In both versions I installed NOISE REDUCTION is not working.

    I am dumbfounded and feel like it must be something simple. Any reasonable suggestions are welcome.

    I've always been able to unzip cooledit, select the two choices and get to work with no problems.

    Thanks a lot. I'm new to the forum but I'll contribute regularly.


  2. #2
    Super Moderator
    Join Date
    May 2003


    I installed CoolEdit 1.53. recorded some noise, about 5 seconds worth. Clicked from the Transform menu the Noise Reduction effect.

    When the dialog box opens the ability to apply Noise Reduction is grayed out. Which apparently this is what your seeing.

    Now what you should do, (unless you are doing this and its still not working then reply back), but at this stage, with the NR box open and grayed out, you should next, click the Set Noise Level to gather the information about the noise you wish to reduce.
    After that runs, the Noise Reduction effect will close. You'll see your waveform window again.

    Now, go back to the Transform menu then select Noise Reduction again. This time, the box should have your noise profile and the OK box will be useable. Adjust the slider to the amount of noise reduction your wish to apply. Click OK.

    If you plan to apply the same Noise Reduction to a music collection, you may want to create a noise profile that your can quickly apply over and over again without going through the discovery process.

    I would do this before recording anything. Create a Noise Profile of the computers internal noise, line-noise, AC 60hz humm, DC noise, Fan Noise, general electronic noise. Unless you happen to have a very electrical clean system. But most people wont as eliminating this type of electronic noise from a computer can be costly.

    If the above does not solve your problem after trying it, then reply back with your results.

    Also, as your using an older version of a CoolEdit with crippled effect. I have written a Howto on this board to gain ALL effect and still be legit.

    To add further, you could always try a great Freeware editor, Audacity, which is what I use today, as I can use it on my new Dual-Core Mac's and my Slackware machines and my MS Windows boxes. It's got plenty of features and its completely freeware.

  3. #3

    Default Thank you but no luck - yet ...

    I'm very glad you tried the program.

    I did the same thing you did. Even though I already have the program I went again and downloaded the
    1.53 version here online and unzipped it into a directory. I then ran the program from cool.exe and recorded
    some audio.

    I selected 5 seconds of a quiet portion of the audio and clicked Transform from the main menu, then clicked
    Noise Reduction. The window opened and like before the 'Set Noise Level' button is greyed out.

    I wish I could think of why this might be happening. I've used cooledit about 1 - 2 times / year since
    it came out 10 years ago and have never had a problem.

    I've done on location sound recording (analog) for many years when I was in college and have always enjoyed
    audio as a hobby that I understand quite well. I also understand the computers well since I got a degree in electronics
    in 1972 <= old old old man. hehe.

    It's a mystery to me and all I can figure is that I must be missing some kind of dll file or otherwise a path problem
    or something that cooledit noise reduction needs to gather the noise data. Please don't go down this path or
    we might both be wrong.

    I'm clueless .. I do understand about saving noise reduction files (the .FFT files) and I have some from a previous
    use of NR in CoolEdit. Mine are dated 10-18-06 so that's the last time I used CoolEdit on my computer and it
    evidently worked fine since I created 3 FFT files with it. By the way I said I was not able to load them and use
    them as fodder to run the noise reduction routine so that's odd too.

    I appreciate your help.

    I have a couple of simple Q's :

    What's the best way to find your write up on uncrippling CoolEdit? Search your username or another way?

    Can I post a photo to the forum? If so I'll show the screen as I see them if that might help. I don't have or use
    any photo posting site but I could perhaps find one in the meantime.


  4. #4
    Super Moderator
    Join Date
    May 2003


    Enabling all effects in Cool Edit

    Since its been a very long time since I used CoolEdit on a regular basis.
    With the installed CoolEdit 1.53. I am trying to get the same problem as you, but no matter what I do. It works.

    Try selecting a larger section for NR, try 20 seconds or larger. I know CoolEdit has problems with very small selections. Though 5 seconds should have worked. I would still try a larger selection just to rule that out.

    The filters in the CoolEdit folder end with the XFM extension. Such as:

    If your old profiles are corrupt, and the last time you used Cooledit, you used one of those profiles. It may be possible that its trying to load that old corrupt profile. But I do not have any corrupt profiles to determine if this is true or not.

    Although CoolEdit is a great program, even these dated versions work well when they work. I'd try using Audacity. As Audacity includes the abilities to do MP3 compression, If thats a how the final product will be compressed to. While the older versions of CoolEdit do not.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts